Foro de debate

Problema con librerias github

 
Imagen de Julian Moyano Di Carlo
Problema con librerias github
de Julian Moyano Di Carlo - lunes, 26 de marzo de 2018, 11:51
 

Buenos dias. Uso el paquete R-UCA (version 3.4.3/2.4-1) y estoy teniendo problemas al instalar paquetes del repositorio github. 

Primero instalo lalibreria "devtools" sin problemas pero despues al utilizar la funcion install_github("vqv/ggbiplot") me da el siguiente error:


[3] NOTA: Downloading GitHub repo vqv/ggbiplot@master

from URL https://api.github.com/repos/vqv/ggbiplot/zipball/master

Installing ggbiplot

"C:/PROGRA~1/R/R-34~1.4/bin/x64/R" --no-site-file --no-environ --no-save --no-restore --quiet CMD

INSTALL \

"C:/Users/Julián/AppData/Local/Temp/Rtmp2R78Hh/devtools315c3ca21869/vqv-ggbiplot-7325e88" \

--library="C:/Users/Julián/Documents/R/win-library/3.4" --install-tests


Installation failed: Command failed (1)


Alguien sabria cual es el problema? Ya he intentado todo y no hay manera de instalar.


Gracias, saludos!

Imagen de Manuel Muñoz Márquez
Re: Problema con librerias github
de Manuel Muñoz Márquez - jueves, 29 de marzo de 2018, 10:36
 

Buenas:

En linux se instala correctamente.

Cuando hago un check encuentro varios errores, posiblemente debido a que el fichero NAMESPACE no contiene las instrucciones correctas para la carga de las dependencias que en las versiones nuevas de R son obligatorias.

Tal vez actualizando dicho fichero funcione, ¿qué tal si le escribes al autor?

Un saludo.

Imagen de Julian Moyano Di Carlo
Re: Problema con librerias github
de Julian Moyano Di Carlo - jueves, 5 de abril de 2018, 12:45
 

Muchas gracias. Lo intentaré


Saludos